999ci hd si problem - need help

Anything Related to the Humminbird 11xx, 9xx, 8xx, 7xx also known as CORE series Units
Post Reply
andreandreasi
Posts: 4
Joined: Mon May 05, 2014 10:46 am

999ci hd si problem - need help

Post by andreandreasi » Fri Jan 01, 2016 11:17 am

Hi

I have a 999ci that got stuck into a dark screen when i try to power it on. All buttons light up but the screen remains dark and the only way to turn it off is by unplugging the power cord.


Have double checked the batteries, all perfect in voltage and amp, have changed the power cord, have tested the bats and the power cord with my other unit (1199 ) and everything went fine. So definetely its not a power supply problem.

This happened after i turned the unit on with the as pc3 kit. The usb was not plugged into the computer, the 8 AA bateries are all new and just got from the box (duracell alkaline). The unit turned on perfectly, worked for a while but suddenly while i was changing the pages it turned off and since then i cant reboot it. I was not upgrading too. I noticed that the voltage indicator was too low while the unit was turned on with as pc3 kit (something about 8,7 or 9,1 volts i cant remember at all)


I am really really scared since i live in brazil and we got no tech support on fishfinders and its extremely difficult to ship something to usa and also its more difficult to receive things from usa thanks to brazils customs

Please, if someone can help me i would be extremely happy and gratefull as i am desperate. Fishing season starts in month here.

Thanks in advance and happy new year

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest

Created by Matti from StylesFactory.pl and Warlords of Draenor
Powered by phpBB® Forum Software © phpBB Limited
 

 

cron